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Players are grouped into sections based on their ladder ranking.  

In doubles, players swap partners for each set. 

Playing format is round robin. 
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Introduction 
 
 

What is Aggregate Competition?  

 

The term aggregate means to tally or add up. Aggregate competition is a competition in which a players' 

weekly scores are added up and used to determine the weekly and season winners. 

There is a recognition that players may need to miss one or two rounds throughout a season, hence there 

are options within the software to count a fixed number of results which may be less than the scheduled 

number of rounds. 

The Aggregate software works on a round robin (doubles or singles). Players swap partners in the doubles 

format. A grading list (ladder) is maintained with the best players at the top. The list is volatile, meaning 

that players may automatically move up and down the list based on the weekly results.  

Players register in advance (allow 1 hour before the start of play). The registered names are selected 

(ticked-off) on the ladder, and sections of 4, 5, or 6 players are then determined from the selected players. 

The fairest section size for doubles is 4 or 5 players because each player will play one set with every other 

player in the section.  In a section of six players, there will be one player you don't get to play with. 

With sections of 5 or 6 players, each player plays 4 six-game sets. With 4 players in a section, each player 

plays 3 eight-game sets. In either case, the maximum score for a player is 24 games. The competition 

organiser may determine the set length but ensure that each player can reach the same total games.  

The grading list can become congested with dead-wood (players who are not attending for various 

reasons). The dead-wood drastically affects the movement of players up and down the list. For example, a 

player coming first will generally move up the list by approximately five places; if the 5 players above are 

dead-wood, then the player essentially moves nowhere in relation to the current players. 

To remediate this, a supplementary list (parking area) is maintained. The dead-wood is moved sideways to 

this list. They are essentially parked there until they return. Players are automatically moved to the 

supplementary list after missing three consecutive rounds (this number can be changed in the Preferences).  

When the player resumes, he/she can be returned to the main list. Enough information is recorded in the 

supplementary list to return a player to approximately the same relative position where they were 

previously (amongst the same players they were with). Returning a player to the same Position Number as 

before is not a reliable indicator of their previous relative position. You may elect not to use the 

supplementary list by changing a setting in the Preferences. 

The program caters for a combined list of male/female players which can, if required, produce separate 

progress results for the female and the male players. Competitions could also be run for male only and 

female only groups. 

Score sheets are generated and printed for the day's play.  

At the end of play, aggregate scores are entered manually, and the grading list is updated automatically 

based on the score for each player. Only the tally score is recorded. Individual set scores are not recorded.  

You may not wish for the grading list to change automatically. This can be accomplished by 

changing settings in the Preferences.  
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Starting the program 
 

Start the program in the usual way by clicking a shortcut icon. Shortcut icons are usually found 

in one or more of the following places: 

 On the Taskbar 

 On the Desktop (this one requires a double-click) 

 On the Start Menu 

 In the All Apps section of the Start Menu under alphabet group A 

o Windows 10 – Look in the Aggregate Competition folder. 

o Windows 11 – The icon is not in a folder. 

 

See the next page for a layout of the program’s User Interface. 

 

After starting the program, the next step is to open the competition (see page 4 for creating a competition). 

 

 

 Click the Open icon on the toolbar as shown circled in the 

picture at the right. 

 

 

 

 

 A list of competitions is displayed. The diagram at right 

shows two in the list – Senior and Super19.  

 

 Click the required competition. 

  

 

 

 

Note: If there is only one competition, it will open automatically without showing a drop-down list. 

 

If you operate multiple competitions at the same time, you can open the program multiple times, 

once for each competition. 
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The User Interface (after opening a competition) 

 

 

  

Menu Bar 

Tool Bar 

Club name 

Competition name 

Club logo 

Status Bar Copyright and version information 
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Create a New Competition 
 

 
1. File > New Aggregate Competition 

a. Fill in the details and click OK. 

b. Note that the Competition Name and the Folder Name are 

usually the same but may be different. The competition name 

is used on report headings. The folder name is where the 

competition files are stored and is also displayed on the list of 

competitions when opening a competition. 

c. You can choose between singles or doubles competition. 

d. Click OK when done. The program will now shutdown – start it up again to begin using the new 

competition. 

 

2. Open the new Competition 

a. Select Open on the toolbar as shown at right. If you 

have multiple competitions, a list is displayed. 

 

3. Enter Player Names 

a. Names can be imported from a comma delimited file 

File > Import Players (See page 31 for more details) 

 

b. Names can be entered manually 

Players > Add Players > Add to End of List 

i. Players are ranked in the order you enter them 

 

4. Enter Court Details (see page 29 for more detail) 

Tools > Court Details  

Each Court must have a Bank number (Location). This is used when 

automatically assigning courts on a rotational basis. Courts must be 

added in sequence (no gaps in the Bank numbering). For small 

venues, all courts will exist on Bank 1. 

 

5. Enter the Start Month 

Tools > Preferences --> Aggregate (Tab) 

Change the Calendar Month value to the Month your competition is due to start. It should already be 

correct from the information entered when creating the competition. Check that the Year is also the 

year the competition starts. 

 

6. Enter the Dates for each round (see page 30 for details) 

Tools > Round Dates 

 

Starting a New Season 
Tools > Start New Season 

This option is used at the beginning of each season. It removes all scores and dates used in the previous 

season. The number of “games missed” by each player is not reset; it is carried over to the new season. 

 

Then repeat steps 5 and 6 from above. 
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Managing the Player List early in the season 
 
When starting a new season, you will start with data from the previous season (unless this is the first time); 

there will most likely be players on the supplementary list who may never play again. For best 

management, the supplementary list should be cleared early in the season.  

 

It is best to do this at about the third round. Following round three, any player on the main list who has not 

yet played will be automatically moved to the supplementary list, (assuming players are removed after 

missing 3 consecutive rounds – this number is controlled by a setting in the Preferences). 

 

Follow this procedure: 

 

1. Start of Season: Use the current and supplementary lists from the previous season. 

a.  Adjust player positions as necessary. 

b. Clear the old data as outlined on the previous page (Tools > Start New Season)  

c. Add dates for the new season. 

 

2. After completing 3 rounds (and before posting results for the next round): 

a. Print the Supplementary List (use this list for reference purposes). 

b. Clear the supplementary list.  

i. Players > Archive > Move Supp List Players who haven’t played yet – To Archive List 

1. The Supplementary list players will now appear on the Archive List, and 

2. The Supplementary list will probably have no (or very few) names on it. 

 

The Player Statistics report is also affected by the supplementary list. This report shows the number of 

players who have played in each round. In addition, it also shows summary statistics for the number of 

players who have played so far during the season. See the YTD figure in the diagram below. 

 

The YTD (Year to Date) figure will not be accurate when there are players on either the main or 

supplementary lists who have not played yet. Hence, the summary statistics are not reliable until after the 

supplementary list has been cleared. 

 

______________________________________________________________________________ 

 

 

The picture below shows the stats after Round 3 (and before clearing the Supp List).  

The real YTD numbers will be Male = 60, Female = 12. The figures of 128 and 37 include players on the 

Supplementary List who haven't played a game in the first 3 rounds. 

To print the above statistics report, select the Menu Option: 

 Reports > Other Reports > Statistics > Player Numbers 
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Entering players for the day’s competition 
 

Quick Guide 
 

 
1. Select the players from the Entries list (Click the Name or Entry column) 
 

a. Mark players who require an Early Finish or Late Start 
 
 
2. Allocate the Sections 
 
 
3. Allocate the Court Captains 
 
 
4. Allocate the Courts 
 
 
5. Print the Player List (Post copies for general viewing) 
 
 
6. Print the score sheets 
 
 
7. Attach Score Sheets (& money bags) to clip boards 
 
 

Description of column headings on the Entry Screen 
 

Column Heading Description 

Pos Shows a Players current position on the grading list 

Sec Marks the start of a section and shows the Section Number. 

Player The Player Name; starting with the Surname. 

Entry Displays a Red tick () to show a player is selected to play. 

EF Early Finish. Coloured PINK when selected 

LS Late Start. Coloured BLUE when selected 

CC 
Shows how many times the player has been Court Captain. 
Also, coloured ORANGE to show today’s Court Captains. 

S4 The number of times a player has been in a section of 4 

S6 The number of times a player has been in a section of 6 
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The Entry Form 
 
 
 

 
 
Round number & date 

Number of players selected 

Number of section markers 
in the Sec column 

 
 
Number of sections 
if you use Auto Sections. 

Shows the number of  
sections with 4, 5 and 6 
players.                                                                                                                                                                                                                                                        
 
 
 
 
 
Column Headings 
 
 
 
 
 
 

 
 
The Clear Players option on the menu bar will remove all ticked players and other marks on the 

page. 

 

Sections with 5 players have a gold colour, sections with 4 players have a green colour, and 

sections with 6 have a blue colour. Any other number has a red colour. 

Status Information 

Section markers A tick to show players 
who have entered 

Early Finish 

Late Start 

Court Captain 

Shows how many times a player has been in a section of 4 & 6 
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Detailed Guide 

 
A backup will occur automatically when you click the Entries icon. 
 

 

Click the Entries Icon on the toolbar as shown at right.  

 
 

 

If you need to skip a round (Washed Out, Heat Policy etc), then 

select Skip Round from the Other menu as shown on the left. 

 

 

 

Step 1: Select the players, including Early Finish and Late Starts if applicable. 

 

 Click the Players heading to toggle between Alphabetic & Numeric sorting of players. 

 

 Click the Entry column (or the player’s name, or the player number) to enter a player.  

o The player's name will be spoken, and a red tick will appear in the Entry column. 

 

 

 

For Early Finish, click the 

E.F. column. It will turn 

PINK. 

 

For Late Start, click the 

L.S. column. It will turn 

BLUE. 

 

To reverse any of the 

above, click again. You 

will be prompted to 

confirm the change. 

 

 

 HELP in finding Names: (First SORT the list alphabetically), then 

o Press the first letter(s) of a player surname, and names starting with those letter(s) will appear; 

the first of those names will be highlighted in blue. 

o You may then press the Space Bar to enter that person or click in the Entry or Name column. 

 

Adding Players to the List 

Before adding a player to the list, you must know the position number at which the player will be inserted. 

After inserting one or more players, the positions of current players will change, hence you cannot use a 

static printed list to determine the next new player's position. You must determine the new position by 

referring to the newly numbered list on the screen. 

 New Player:  

o Click the Add New Player button. Fill out the details on the popup 

screen. Change the Gender as required. The Gender defaults to the 

setting in the Tool s > Preferences > Other – Default Gender.  
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 Supplementary List 

o To restore a player from the Supp List, click the Supplementary List button.  

o Click the name to be restored. 

o Note: the popup window requesting the position for this player includes details about the 

players who were immediately above and below the player when he/she was removed. If a 

position is shown for the before and after players, it is their current positions on the list. 

 

o Players restored in this way are automatically marked for play with a red tick (). 

 

 
Step 2: Allocating the Sections 

 

You can manually select the starting player for each section by clicking in the Sec column. A Section 

Number will appear in the column; existing section numbers will be adjusted to suit. The marker for Section 

1 can’t be moved. It is always at the top of the Sec column, even when the first player is not playing. 

 

The sections can be determined automatically as follows (but not for Singles competitions): 

 

 Click the Auto Sections Button 

o If there is an even multiple of 5 players, the sections will appear immediately. 

o If there are sections of 4 or 6 involved, small tables will appear on the screen; one for each 

section of 4 or 6 players. See below for an explanation of these tables. 

 Click the Save option when the sections of 4 (or 6) have been selected. 

o The player list will now show the sections and be sorted by player position. 

 

 Sections with 5 players will be marked with gold, Sections of 4 with green and Sections of 6 with blue. 

 

The automatic selection of sections has the following advantages: 

 Allows you to share the exposure to odd sections (4 or 6 players) between all players. 

 Can avoid having Early Finish players in Sections of 6 and Late Start players in sections of 4. 

  

Column description for the Section Tables (Each row shows statistics for the section) 

 

1. Section Number 

2. EF or LS: will show a "1" if there is a player requiring an Early Finish (or Late Start in a 4 section)  

3. Total6: the number of times all players in the section have been in sections of 6 

4. Total4: the number of times all players in the section have been in sections of 4 

5. MaxPlayer6: maximum times any single player has been in a section of 6 

6. MaxPlayer4: maximum times any single player has been in a section of 4 
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The first table is for the 1st section of 4 or 6 players, the second table is for the 2nd section of 4 or 6 players, 

and so on. There can be up to four tables depending on the program Settings. 

 

 The Section Numbers must increase in value from table 1 to table 2 to tables 3, etc. 

 Click in the Section Number column to choose a section. 

 Click Save on the Menu bar after marking the required sections (or press the <Esc> key to abort). 

 

The tables are sorted such that the sections at the top of each table are the ones to be considered first. 

 

The table above shows that Sections 1 and 2 have been selected to contain 6 players. 

 

The following table shows that Sections 6 and 7 have been selected to contain 4 players. 

 

 
 
 
 
 
Step 3: Allocating Court Captains 

 

You can manually select a court captain by clicking the CC column for the player. The cell will turn ORANGE.  

A second click will remove the ORANGE selection. 

 

However, Court Captains should be determined automatically as follows: 

 

 Click the Court Captains Button (shown to the right) 

 

 Court Captains will immediately appear highlighted in ORANGE.  

 

 

 

The automatic selection of Court captains applies the following rules (where possible): 

- Exclude new members added to the list for the first time 

- Avoid players with an Early Finish or Late Start 

- Select a player in the section who has been Court Captain the least number of times. 
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Step 4: Court Allocation 

 

 If you need to make a change to the court data e.g. mark a court as unavailable, it can be done from the 

Entries Screen by selecting the menu option: Other > Court Details. 

 

The Court Allocation can be done automatically, manually or randomly. Click the courts button to show the 

following options. You may also skip court allocations, in which case no court numbers will be printed on 

the score sheets. 

 

 

After selecting one of the three options, a table of courts, similar to 

the one on the right, will be displayed. The X on the table shows 

courts that have been marked as unavailable. The R shows courts 

that have been reserved by other competitions; to change the 

reserved courts you must go back to the competition that reserved 

them and re-allocate the courts. 

 

If you select automatic or random, the section numbers will be 

inserted automatically. The automatic selection process tries to 

rotate the courts by allocating a different bank and court to each 

player on a weekly basis.  

 

If you select manual, no section numbers will be shown. You must 

manually enter each section number next to a court number. 

 

Automatic and Random Allocation - Not enough courts 

If there are not enough courts available for the number of sections, 

you will be given the option to select the courts manually. You may 

then allocate a section to a court that was previously marked 

unavailable by overwriting the X. 

  

Save the Court Allocation 

When you are happy with the court allocation, click the Save option at the top. To exit without saving, 

press <Esc>, or click the X in the top right corner of the window. 
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Step 5: Print the Player List 

 

 Click the Printing option on the menu bar, then select 

Print Today’s Player List 

 

 Click OK on the Printer Settings screen (or press <Esc> 

key to abort) 

 Review the printed list for accuracy 

 The list shows: 

o the section numbers 

o the court number (if courts have been allocated) 

o the players in each section 

o the player’s position from the master list 

o player codes – CC, EF, LS (Court Captain, Early Finish, Late Start) 

o newly added players are identified by *** with a code appended as follows: 

 (N – new player, S – From the supplementary list, A – from archive list) 

 

Step 6: Print the Score Sheets 

 

 Click the Printing option on the Menu Bar, then 

select Print Score Sheets.  

 Click OK on the Printer Settings screen (or press 

<Esc> key to abort). 

 Select which sections are to be printed, then click OK. 

 The score sheets will now be printed.  

o Printing of the score sheets may take a while on older printer models. 

 

 The Order of Play Schedule on the score sheets will be printed 

to reflect any Early Finish or Late Starts. Play must start with the 

first match and follow the schedule for the remaining matches. 

 

 

 

 

 

 

 

 

 

Save:  
 

After making changes on the Entry Screen, you must remember to SAVE 

the changes. This is done by clicking Save on the menu bar or clicking 

Save on the File menu.  

It is advisable to Save your selections prior to printing the player list and 

score sheets. If you exit the Entries screen without saving, you will be 

prompted to do a save. 
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Entering the Scores 
 
A backup will occur automatically when you click the Results icon. 
 
 
To enter the scores, click the Results Icon on the toolbar as 

shown at right. Only the tally score for each player is 

recorded. The scores for each set are not recorded. 

 

 

 

 Note: after typing 2 digits, the cursor will automatically move to the next field. For a single digit 

score, put a 0 in front. e.g., 09 for a score of 9 games (or type 9 and press the Enter key). 

 Click the Save button after completing the scores for the section. 

 After clicking save, the next section of players will be displayed. 

 Click the X (top right) or press the <Esc> key after all sections have been entered. 

o You may enter the sections out of order by changing the Section Number at the top. 

o You may come back to a section and make changes; Beware: the order of names will be 

different as the players have now been sorted according to the scores you already entered. 

Posting the Results 
A backup will occur automatically when you click the Post Results icon. 

1. Apply the results by clicking the Post Results Icon on the toolbar. This step moves the players on the 

list to their new positions and removes players who have missed 3 consecutive rounds. To avoid any 

movements, change the movement settings in the Preferences section to zero. 

2. Select Weekly Trophy winners if applicable – Click the Trophies Icon on the toolbar 

3. Make any required name changes and other alterations. 

 

 A backup will occur automatically when you click Entries for the next round. 

 This backup will be for the end of the previously completed round. 
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Printed Reports:  

Notice Boards Reports 

i. Results 

ii. Player List - Full 

iii. Aggregate Progress 

 

Match Committee Reports: 

iv. Player List - Brief 

v. Supplementary Player List 

vi. Trophy Winner Cards  

vii. Alphabetic list 

viii. Mini Aggregate: shows the players’ total games between any two 

selected rounds. 

ix. Player List – Names Only (Four columns) 

x. Player List – Names Only (PDF). Creates a PDF file. 

 

 

Publishing to a Web Site (optional): 

Use the Create HTML Reports option. Your website administrator will copy the files to your website.  See 

the Web Guide for detailed instructions. 

 

Publishing Reports (for printing) 

The PDF files created with “Create PDF files” will serve as a good record of the status after each round, 

and provide an option to re-print a report from an earlier round. 

 

There are settings in the Preferences  Folders tab, which set the location of Folders for the HTML & 

PDF files. Make sure these folders are different for each competition. This won’t be a problem unless 

you change from the default locations. 

 

Send the results to the Media (optional): Media Report 

When printing the Results, you are prompted to create a media report. This option creates a text file 

which can be emailed to the media/newspapers. You choose the file name. If there are multiple 

competitions, you can append all competition results into a single text file. 

There is a setting in the Preferences  Folders tab for the location of the media reports. 

 

 

Automatic Removal from the Ladder by Games Missed 

"Games Missed" is the number of games missed in succession and is updated at the end of the Result 

Processing. Players are automatically removed from the list if the number of games missed is equal or 

greater than the ‘Games Missed’ value in the Preferences (usually set to 3). Players removed at this time 

are placed on the Supplementary List. You could set this value to zero for no removal of players. 

 

Before & After Positions 

The before and after positions printed on the Full 

Ranking List are not altered by the manual adjustment of 

players. These figures are taken immediately before and 

after the Results are applied. The before position may be 

different to the previous week’s published position due to 

players being added, removed or re-graded. 
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Sharing the Courts (Still in development) 
Each competition file is self-contained, meaning that all data exists in a single file (Agg.mdb), 

including the court allocations. This presents a problem if you run multiple competitions that use 

the same complex of courts at the same time. You might end up allocating the same court in each 

of the competitions. You might allocate a group of courts for each competition, or … 

You can setup the shared courts option as shown below. A new data file called courts.mdb is used. 

The file resides in the dBases folder and may be shared by all competitions. When courts are 

allocated, they are now marked as reserved for all competitions using the shared courts option. 

Shared Courts Setup 
To change your competitions to use the shared 

courts file (courts.mdb), you must make a change 

in the Preferences; go to Tools > Preferences and 

click the Entries TAB.  

Select the option shown below. You must do this 

for each competition that shares the courts. 

 

 

 
 

After making the change, and clicking the OK button, you will be prompted to close the Aggregate 

program. Make sure you close and then re-start the program. 
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The courts.mdb file is shown here circled in 

red. The file resides in the DBases folder. 

When courts.mdb is first created, it is 

populated with court data from the original 

court details in your competition file. 

 

If you delete the courts.mdb file, it will be re-

created the next time you open a competition 

using the shared courts option. 

 

NOTE: The shared courts option is still 

under development. 

 

 

 

 

 

Alternatives for working with Court Data 

 

Competition / Court Usage 

Use this setting (in the Preferences) 

Each competition manages 

courts independently 

Courts are shared between 

all competitions 

Single competition � � 

Multiple competitions 

sharing all courts 
� � 

Multiple competitions 

each having their own courts 

(Sharing not required) 

� � 

 
  

When running a number of competitions at the same time, you should open the 

Aggregate program multiple times while doing the player entries: once for each 

competition. 
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View and Edit Player Details 
 

 

To view players from any of the lists, 

just click the appropriate icon on the 

Toolbar.  

 

The Player List 

 
When the player list is first displayed, the 

names are sorted by their ladder position, 

starting at 1. To sort the names alphabetically, 

click the heading at the top of the Surname 

column as shown.  

 

When the list is sorted alphabetically, you can press the first letter(s) of a surname to move immediately to 

that part of the list. 

 

To view additional data, or to change details for an 

individual player, right-click the player's name.  

 

A popup menu appears, as shown to the right, with the 

following options: 

 

View Player Results displays a table showing all results for 

the player. There is an option to print these results. 

 

Edit Player Details allows you to make changes to the player's name, gender, etc. 

 

Move Player to a New Position allows you to manually adjust ladder positions. Pick the number of the 

player that the moving player should be ahead of. 

 

Move Player to the Supp List: the player is taken off the main list and placed on the supplementary list. 

 

Edit Scores: Allows you to alter a score, or to add the player's score for a particular round.  

 

You should not change a score if it would affect the winners or losers in the section. In such a case, you 

would revert to a previous backup file and re-enter the scores. 

 

This option could be used if the same player was entered under different names. In such a case you would: 

 Remove the incorrect name to the supplementary list (make a note of the round scores first) 

 Use Edit Scores to enter the round scores to the correctly named player. 

 You could also use the option to merge the players. This option is on the Players menu. 

 

The Supplementary List and Archive List are sorted alphabetically. The Supplementary list displays 

additional information relating to where the player was originally positioned on the main list. On the right-

click menu for Supplementary List players, there are three options; View their results, Move to the Main 

List, and Move to the Archive List. 

 

The Aggregate list shows the current standings for most games won.  
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Program Settings - (Preferences) 

 
The settings are accessed from the Menu bar Tools > Preferences 

 
Aggregate Page 
 

 
 
Year: Defines the start year of the competition. 

 

Start Month: This is used to set the starting month on the calendar for selecting the Round Dates. 

 

Games Counted towards Aggregate: can be set as a % of total games or entered as a fixed number. 

 

Priority for tie: This setting applies to a tie for first place. Ladder Position means that the higher player on 

the ladder wins. If there is a tie for 2nd place, the Ladder Position rule applies. 

 

Last Player doesn't go down (the mercy rule)...: If this option is enabled, then the last player doesn't drop 

down the list if winning the number of games specified. The number of games can be altered to suit. 

 

Block the 2nd player ... : If this option is enabled, the player coming 2nd in a section cannot move higher than 

the position of the last player in the section above. 

 

Movement values: You can change the movement values for the winner, 2nd and last players. If you wish to 

manually move players (or not move them at all), set the movement values to 0. 

 

Maximum score per round: This value is used as a check for typing errors when entering results.  

 

Competition Type: Select between Doubles and Singles.  
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Entries Page 
 
 

 
 

Priority for determining the makeup of sections 

These settings determine how many sections might have 4 or 6 players. The aim in aggregate competition is 

to have 5 players in a section (doubles play), however, you can't control how many 

players will elect to play on any day. If there is not a multiple of 5 then the above 

rules will apply when automatically creating sections. 

 

Maximize 5 player sections: With this option you may also end up with  

 one or two sections of 4 players, or 

 one or two sections of 6 players. 

o There will never be a mixture of 4 and 6 players sections; it is one or the other. 

Avoid sections of 4 players: With this option, as well as having sections of 5, you may also end up with: 

 one, two, three or four sections of 6 players. 

Avoid sections of 6 players: With this option, as well as having sections of 5, you may also end up with: 

 one, two, three or four sections of 4 players. 

Managing Court Allocation 

 These settings determine if the shared courts.mdb file is used.  See the earlier section on Sharing 

courts.  
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Missed Games Page 
 
 

 
 
 

 

These options determine what happens to players if they miss a number of matches over successive 

rounds. 

 

 

Remove players after missing a number of rounds 

 If a player misses the specified number of rounds, they are moved to the supplementary list. 

 

The supplementary list is a parking area for players; when the player returns, they can be moved back to 

the main list in roughly the same logical position where they came from. Logical position means: amongst 

the same group of players. 

 

Remove the tick from this option if you don’t wish players to be removed from the main list. 

 

 

Relegate players after missing a number of rounds 

 If this option is enabled, a player will automatically drop down the list by the specified number of places if 

they miss the set number of matches over successive rounds. 
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Score Sheet Page 
 

 
 
 

Draw Sheet Type 

The draw sheets can be printed with or without groups. The groups system allows for the sharing of courts 

between sections in the same competition; you can have 3 sections sharing 2 courts, or 4 sections sharing 3 

courts. This is useful when the number of courts is limited. A table is printed on the score sheet showing 

the order of matches to be played on the shared courts. 

 

Example 

Three sections share two courts. The three sections are identified by groups A, B and C. 

The order of play will be: A1, B1, C1, A2, B2, C2, A3, ... 

A1 = Match 1 from group A, C2 = match 2 from group C, etc. One court captain from the three sections is 

responsible for ensuring that the scheduled order of play is maintained. 

 

Competition Fee 

If you charge a competition fee it can be entered here; the amount will then be printed on the score sheets. 

 

Printer Offset 

Implemented to allow for different printers printing in slightly different positions on the page. This was only 

useful when score sheet image templates were being used. They are now only used for singles. 

 

Notices For Players 

Text entered here will be displayed on the score sheet.  
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Club Name Page 
 
 

 
 
 

Club Name: Your club's name is hard coded in the program reflecting your club's purchase of a 

licence to run the software. Changing the Club Name here will have no effect. 

 

 

Competition Name: The name here is used for the headings on printed reports. The word 

'Aggregate' is appended to this name for the report headings. 
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Folders Page 

 

 
 

 
 
 

Media Report: Refers to the Media Report created when printing the results for the round. You can select 

here where the media report will be saved. 

 

The PDF Folder and HTML Folder paths are the locations where HTML and PDF files are saved when using 

these report options. Check the Folders Structure on page 27 to see where they are created.  

 

If you change the paths from the default values, make sure that: 

 each competition uses a different folder, and 

 you change the path at the start of each new season, 

otherwise, the files from the previous season will be overwritten.  

 

The HTML files may be copied to a web site. See the Web Guide for more detail. 
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Other Page 
 

 

 
 

 

Print Rank Numbers on the Full Player List: 

Prints numbers as shown.  

 

 
 
 

 

 

Keypress delay when doing a Name Search: When searching for a name in the Entries (and other) lists, 

this value determines the time allowed between keystrokes. If you take a longer time to press the next key, 

then the search starts over, using the last key pressed. 

 

Default Gender: This is used when entering new players. Set it to F for Ladies competitions, and M for 

Men's competitions. In a mixed competition you may need to manually choose the gender when adding 

new players to the list. 
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Installing the Aggregate Software 

To install the software: 

 You may have received the setup program, Agg2Setup.exe: 

o On a memory stick, or  

o Via an email, or 

o A download 

 Run the program Agg2Setup.exe 

o Depending on your computer settings, the ".exe" may not show in the program name. 

Follow the prompts in the installation program: 

 Welcome Screen - Click Next 

 Destination location defaults to C:\Agg2 - click Next 

 Select a name for the Start Menu Folder: it defaults to Aggregate Competition - click Next 

 Tick the box if you require a Desktop Icon - click Next 

 On the summary window click Install 

o The installation of the Aggregate program only takes a few seconds. 

 

Once the program has been installed, you are ready to: 

1. Create a new competition, or 

2. Copy existing competition files to the appropriate folders. 

 

----------------------------------------------------------------------------------------------------------------------------------------------- 

The installation program file size is about 6MB. 

 

Program updates may be supplied from time-to-time. If the update is supplied as a file called Agg2.exe, 

then you will copy it to the C:\Agg2 folder replacing the existing Agg2.exe file.  

 

If the update is supplied as Agg2Setup.exe then run the program. Running the setup program will 

automatically replace Agg2.exe with the new version. 

 

Note that this guide refers to C:\Agg2 as the installation folder, however you may have installed to a 

different folder. If so, substitute your folder name wherever you see the Agg2 folder name. 

----------------------------------------------------------------------------------------------------------------------------------------------- 

 

Running the program from USB or other locations. 

Once the program has been installed, you may copy the Agg2 folder, including all sub-folders, to a memory 

stick (or any other folder on a computer) and run the program from there. In such a case you would need to 

make a new shortcut to the new Agg2.exe file or run the program directly from the new folder location. 

 

If you do move it to a new location, be careful of the folder paths for the PDF & HTML report files. If they 

were changed from the default locations, then you should check the Preferences as they may now be 

referring to incorrect paths. 
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Backing Up Your Data 

Quick Backup 

The aggregate software has no mechanism for going back to a point in time. 

For example, if you discover that scores were entered incorrectly in the 

previous round, you cannot press any buttons to go back to that round. 

The only way of returning to that point in time is to re-instate the data from a 

backup by using the Quick Restore option. Hence, it is vitally important to have a backup created for 

each of the following critical steps: 

1. Before the scores are entered   - This preserves the Entry data 

2. Before the results are posted   - This preserves the Scores 

3. Before the start of the next round  - This preserves the data for the Round 

Automatic Backup 

As of Version 2.3.0.0 backups are automatically created for each of the above three steps. 

The active data file, Agg.mdb, is automatically copied to the backup folder and saved with the 

following names: 

1. AggXX-Entries-yyyy-mm-dd-hhmmss.mdb  - created when selecting the  Results option 

2. AggXX-Results-yyyy-mm-dd-hhmmss.mdb  - created when selecting the Post Results 

3. AggXX-RoundEnd-yyyy-mm-dd-hhmmss.mdb  - created when selecting the Entries option 

where XX is the round number. The date and time are appended to the end of each file name. 

The RoundEnd backup is done when you select the Entries option for the next round. 

If you select the options Results, Post Results or Entries more than once, the backup file is 

automatically created at the first selection, and on subsequent selections you will be asked if you 

wish to create another backup file. 

Manual Backup 

You can still manually backup the active data file at any 

time. Prior to version 2.3.0.0 you had to close the 

competition file before creating a backup. This is no 

longer the case.  

Select Quick Backup from the File menu. When you 

perform a Quick Backup you will be presented with a 

File Explorer window in which you must enter a name 

for the backup file. It is suggested that you use a similar naming convention to the above.  

Off-line Backup 

The above Backup files are stored on the same disk as the competition file. If this disk were to fail, 

you would lose both the main file and the backup files. Hence, it is important to regularly copy the 

whole Agg2 folder structure to an external disk, such as a USB memory stick. 
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Court Setup 
 

The inclusion of your court layout in the software allows you to allocate a court to each section, and hence 

print the court number on the score sheet.  

When a new competition is created, one of the first steps is to define your court 

layout. This is done from Tools > Courts Details. You will use this same option 

from time-to-time to make changes to court availability. 

The court details window is shown at the right. By default, it has the capacity to 

define up to 30 courts (there are 30 rows in the table). 

If your complex has more than 30 courts, click the Add Rows menu option and 

insert the number of additional rows required. 

You must place a number in the Bank column for every one of your courts. The 

Bank number is a representation of the court location. 

 

In this example there are 22 courts, consisting of:  

The first 4 courts on Bank 1 

The next 10 courts on Bank 2 

The next 4 courts on Bank 3 

The final 4 courts on Bank 4 

The table would be completed as shown at the right. 

If you are not concerned about players being on a different bank of 

courts each week, you could identify all courts as Bank 1. 

To mark courts as unavailable, click in the Availability column; an X 

will then mark the court as unavailable. Click again to remove the X. 

Courts may be unavailable because of repair, or because you simply 

don't wish to use those courts. 

 

When finished, click the SAVE option on the menu bar.
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Round Dates  
 

 

At the start of a new competition the round dates must be selected. This is done from Tools > Round Dates. 

You will see a calendar, as shown below, starting at the month you previously selected in the Preferences. 

The calendar show today's date circled in red. 

  

 
 

To select a date, click it with the mouse and it will be bolded. Click again to remove a date. Note that the 

bolded dates can be difficult to see on some screens. 

On the calendar above, dates have been selected from October 8 through to March 25. On the menu bar 

you can also see the number of rounds selected (22 in this case). 

When finished selecting dates, click the SAVE option on the menu bar.  

 You cannot add or remove a date that is earlier than the last round scores that have been entered. 

On the status bar of the main window (bottom left corner) you can see how many rounds have been 

scheduled. Here you will also see the number of the last round completed and the number of players on 

the main list. 

 

Other indicators will show on the status bar to the right of the 3 items listed here. These occur when 

entering players, and when entering scores.  
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Import Files 

 

You can create a comma-delimited file using either Excel or Notepad. Player names are not case sensitive, 

(lowercase is OK). There are two options for formatting the names. 

 

For Excel 

 

 Format Option 1 

o Surname in column A, Given Name in column B, Gender in column C (F or M) 

 

 Format Option 2 

o Given Name and Surname in column A, Gender in column B 

 

 When all names have been entered, position the cursor in an empty cell at the end of column A 

 

 Save the file as follows 

o File > Save As 

o Select File Type as “CSV (Comma Delimited) (*.csv)” 

o Name the file appropriately, e.g. PlayerNames.csv 

o Click the Save button 

 

For Notepad 

 

 Format Option1:  

o Surname, Given Name, Gender (note the comma between the three items) 

 

 Format Option 2: 

o Given Name Surname, Gender (note the comma between the two items) 

 

 One player per line 

 

 Save the file 

 

NOTE: If all names are Male, or all names are Female, you may omit the Gender. It can then be selected in 

the Import option within the program. 

 

In the Aggregate Program, import the names as follows: 

 

 File > Import Players 

 You must then select the Format option and Gender option. 

 Select OK to continue 

 Select the csv (or text) file you created with Excel (or Notepad) 

 Select Yes to start the import. 

 

The names will be added to the end of the existing player list, ranked in the same order they appear in the 

file. 
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Other Considerations 
 

Early Finish and Late Start 

 There are some restrictions when players request an early finish (EF) or a late start (LS).  

 There are no problems if there is only 1 player in a section requesting either an EF or a LS 

 In a section of 5,  

o only one player can have an EF, and/or one player with a LS 

o When there is an EF and a LS, the following player combinations will not work:  

 Player-1 EF / Player-2 LS 

 Player-2 EF / Player-3 LS 

 Player-3 EF / Player-4 LS 

 Player-4 EF / Player-5 LS 

 Player-5 EF / Player-1 LS 

 (The program will warn you if these combinations exist). 

 In a section of 6,  

o two players can have an EF 

o two players can have a LS 

o you can have one each of EF and LS (there are no restrictions as there are with sections of 5) 

o Early finish in a section of 6 will finish at the same time as the last set in a section of 5. 

What if a player retires before the end of play? 

If the retirement is early in the day's play, it may be possible to restart with one less player in the section. A 

section of 6 would become a section of 5. A section of 5 would become a section of 4. A section of 4 would 

be become a non-event for doubles play. 

You must remember to remove the retired player from the entries list prior to entering the scores. 

If the retirement is later in the day you will need to have a different plan such as: allocate average scores to 

those who would lose the remaining sets; or call on a player from another section; or cancel the section.  

If you cancel the section, you must: 

 remove the players from the entries list (prior to entering the scores) 

 manually re-enter the court numbers because they would now not match the original court 

allocations. 

What if scores have been entered incorrectly? 

If scores have been entered incorrectly, and this is not discovered until after the posting of results, you 

have two options: 

1. Edit the scores (see the section for "View and Edit Player Details").  

a. This should not be done if the changes affect the winners or losers of the section. 

2. Restore the backup file called Aggxx-Results-yyyy-mm-dd-nnnnnn.mdb 

a. fix the scores, and then  

b. re-post the results. 
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What if a program error occurs? 

If a serious or fatal program error occurs, you will most likely see an error message window. Exit the 

program and re-start it. Check that your data is OK and try again. In such cases there is usually no loss of 

data. 

 

In such cases, make a detailed note of exactly what you were doing at the time (e.g. printing score sheets, 

posting results, etc). The more detail the better.  Pass this information to the programmer at your earliest 

convenience. 

_______________________________________________________________________________________ 

If an error occurs while posting the results, there may be an issue with the same player being on both the 

main list and the supplementary list. The program has been modified to try and stop this from happening, 

however if it does happen, remove the player from the supplementary list prior to posting the results. 


